madlib-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iyerr3 <...@git.apache.org>
Subject [GitHub] madlib pull request #197: Fix madlib version parsing for upgrade
Date Mon, 13 Nov 2017 23:29:43 GMT
Github user iyerr3 commented on a diff in the pull request:

    https://github.com/apache/madlib/pull/197#discussion_r150697403
  
    --- Diff: src/madpack/upgrade_util.py ---
    @@ -142,11 +142,11 @@ def _load(self):
             """
     
             # _mad_dbrev = 1.9.1
    -        if self._mad_dbrev.split('.') < '1.10.0'.split('.'):
    +        if map(int,self._mad_dbrev.split('.')) < map(int,'1.10.0'.split('.')):
    --- End diff --
    
    The change would have to go in both modules i.e. in `madpack.py` the import statement
will have to be `import upgrade_util` instead of the `from upgrade_util import ...`. 
    Alternatively, you could move the functions to `upgrade_util.py`, thus eliminating the
circular imports. 


---

Mime
View raw message