madlib-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From iyerr3 <...@git.apache.org>
Subject [GitHub] madlib pull request #197: Fix madlib version parsing for upgrade
Date Mon, 13 Nov 2017 22:26:05 GMT
Github user iyerr3 commented on a diff in the pull request:

    https://github.com/apache/madlib/pull/197#discussion_r150684741
  
    --- Diff: src/madpack/upgrade_util.py ---
    @@ -142,11 +142,11 @@ def _load(self):
             """
     
             # _mad_dbrev = 1.9.1
    -        if self._mad_dbrev.split('.') < '1.10.0'.split('.'):
    +        if map(int,self._mad_dbrev.split('.')) < map(int,'1.10.0'.split('.')):
    --- End diff --
    
    Multiple ways to work around that. Ideally, move common functions to a separate module.
But easier solution would be to do `import madpack` instead of `from madpack import ...` and
then use `madpack._is_rev_gte`. 


---

Mime
View raw message