lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [jira] [Created] (PYLUCENE-52) JCC build fails with Python 3.8.
Date Wed, 16 Oct 2019 02:42:56 GMT

That, and, with python 3.8, extensions are not supposed to be explicitely linked against libpython
anymore.
(from the same doc)

> On Oct 15, 2019, at 18:53, A. Coady (Jira) <jira@apache.org> wrote:
> 
> A. Coady created PYLUCENE-52:
> --------------------------------
> 
>             Summary: JCC build fails with Python 3.8.
>                 Key: PYLUCENE-52
>                 URL: https://issues.apache.org/jira/browse/PYLUCENE-52
>             Project: PyLucene
>          Issue Type: Bug
>         Environment: linux
>            Reporter: A. Coady
> 
> 
> JCC build fails with
> 
> {{/usr/bin/ld: cannot find -lpython3.8m}}
> 
> because 3.8 dropped the m flag.
> 
> https://docs.python.org/3.8/whatsnew/3.8.html#build-and-c-api-changes
> 
> 
> 
> --
> This message was sent by Atlassian Jira
> (v8.3.4#803005)


Mime
View raw message