lucene-pylucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andi Vajda <va...@apache.org>
Subject Re: [VOTE] Release PyLucene 6.4.1 (rc1)
Date Mon, 13 Feb 2017 21:46:45 GMT

On Mon, 13 Feb 2017, Jan Høydahl wrote:

> Here is a GIST with complete install log and Makefile. I did not modify setup.py, it
looked good to go
>
> https://gist.github.com/janhoy/c996529dc492ec3ad9cb3b81e80719f2#file-pylucene-install-log-txt
<https://gist.github.com/janhoy/c996529dc492ec3ad9cb3b81e80719f2#file-pylucene-install-log-txt>
>
> In Makefile I customized only these vars
>
>> PREFIX_PYTHON=/usr/local/Cellar/python/2.7.13/
>> ANT=/usr/local/Cellar/ant/1.10.0/bin/ant
>> PYTHON=$(PREFIX_PYTHON)/bin/python
>> JCC=$(PYTHON) -m jcc
>> NUM_FILES=8
>
>
> JCC finds Java Home, and python version is 2.7.13
> My version of ?make? is macOS default gmake 3.81
>
> I also tried with (g)make 4.2.1 but same problem.

Apart from the trailing slash in PREFIX_PYTHON which leads to a // later on 
(which I don't think is the cause of the problem), I can't see anything 
wrong.

Andi..

>
> --
> Jan Høydahl, search solution architect
> Cominvent AS - www.cominvent.com
>
>> 13. feb. 2017 kl. 00.47 skrev Andi Vajda <vajda@apache.org>:
>>
>>
>> On Mon, 13 Feb 2017, Jan Høydahl wrote:
>>
>>> Tried to build on my Mac again, same problem as last time when running ?make?,
the command 'python -m jcc.__main__ --shared --arch ?.? requests old Apple-Java 6:
>>>
>>>> No Java runtime present, requesting install.
>>
>> When building JCC (before building PyLucene), you need to ensure that the proper
version of Java is found. The setup.py program tries to figure it out for you and tells what
it's about to build with on stdout.
>>
>> Then you need to install JCC.
>>
>> Then, when building PyLucene, you need to make sure that the same python install
you used to build JCC is also going to be used by the PyLucene Makefile, since that's where
the current JCC you just built got installed.
>> You need edit that Makefile and uncomment/edit one of the configuration
>> examples to match your setup.
>>
>> I'm sure it also helps if at the command line, you see something like this
>>  $ java -version
>>  Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
>>  Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)
>>
>> If not, fix this before trying anything else.
>>
>> Andi..
>>
>>>
>>> --
>>> Jan Høydahl, search solution architect
>>> Cominvent AS - www.cominvent.com
>>>
>>>> 11. feb. 2017 kl. 23.23 skrev Andi Vajda <vajda@apache.org>:
>>>>
>>>>
>>>> Ping ?
>>>> Two more PMC votes are needed before this release can happen.
>>>> Thanks !
>>>>
>>>> Andi..
>>>>
>>>>> On Feb 6, 2017, at 13:38, Andi Vajda <vajda@apache.org> wrote:
>>>>>
>>>>>
>>>>> The PyLucene 6.4.1 (rc1) release tracking today's release of
>>>>> Apache Lucene 6.4.1 is ready.
>>>>>
>>>>> A release candidate is available from:
>>>>> https://dist.apache.org/repos/dist/dev/lucene/pylucene/6.4.1-rc1/
>>>>>
>>>>> PyLucene 6.4.1 is built with JCC 2.23 included in these release artifacts.
>>>>>
>>>>> Please vote to release these artifacts as PyLucene 6.4.1.
>>>>> Anyone interested in this release can and should vote !
>>>>>
>>>>> Thanks !
>>>>>
>>>>> Andi..
>>>>>
>>>>> ps: the KEYS file for PyLucene release signing is at:
>>>>> https://dist.apache.org/repos/dist/release/lucene/pylucene/KEYS
>>>>> https://dist.apache.org/repos/dist/dev/lucene/pylucene/KEYS
>>>>>
>>>>> pps: here is my +1
>>>
>
>
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message