karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-812) Cannot start bundle built with org.osgi.framework v. 4.3.0
Date Thu, 11 Aug 2011 09:16:49 GMT

    [ https://issues.apache.org/jira/browse/KARAF-812?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13083027#comment-13083027
] 

Jean-Baptiste Onofré commented on KARAF-812:
--------------------------------------------

It's "normal",the version ranges are for 4.2.

I raised Jiras to update the OSGi framework version, and update the version range.

I leave your Jira open and I will link it to the others issues.

> Cannot start bundle built with org.osgi.framework v. 4.3.0
> ----------------------------------------------------------
>
>                 Key: KARAF-812
>                 URL: https://issues.apache.org/jira/browse/KARAF-812
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-osgi
>    Affects Versions: 2.2.3
>            Reporter: Alexey Markevich
>
> I have a project with dependency
>         <dependency>
>             <groupId>org.osgi</groupId>
>             <artifactId>org.osgi.core</artifactId>
>             <version>${osgi.core.version}</version>
>             <scope>provided</scope>
>         </dependency>
> After switching to
>         <osgi.core.version>4.3.0</osgi.core.version>
> There is exception during bundle startup:
> Missing Constraint: Import-Package: org.osgi.framework; version="[1.6.0,2.0.0)"

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message