kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Florian Schmidt <florian.schm...@eforce21.com>
Subject Current master does not build
Date Wed, 04 Sep 2019 10:27:04 GMT
Hello,

I'm trying to compile the current master (commit:
8dc80e22973d89090833cb791d9269e9a0598059),
but the build fails at the tasks :core:compileScala and
:kafka:core:compileScala with the following error:

.../kafka/core/build/classes/scala/main/kafka/api/package.class' is broken
(class java.lang.RuntimeException/error reading Scala signature of
package.class: Scala signature package has wrong version
 expected: 5.0
 found: 5.2 in package.class)

It seems that during compilation the 2.12-compiler uses a 2.13 library!?

Best regards,
Florian

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message