kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Roesler <j...@confluent.io>
Subject Re: [VOTE] KIP-488: Clean up Sum,Count,Total Metrics
Date Wed, 17 Jul 2019 20:09:05 GMT
Hey, Bruno and Bill,

Since you cast your votes before the KIP was updated, do you mind
re-casting just so we can be sure you're still in favor?

Thanks,
-John

On Wed, Jul 17, 2019 at 2:01 PM Guozhang Wang <wangguoz@gmail.com> wrote:
>
> +1 (binging).
>
> This is a great cleanup, thanks John!
>
> Guozhang
>
> On Wed, Jul 17, 2019 at 11:26 AM Ryanne Dolan <ryannedolan@gmail.com> wrote:
>
> > +1 (non-binding)
> >
> > Thanks for the interesting discussion.
> >
> > Ryanne
> >
> > On Fri, Jul 12, 2019, 2:49 PM Ryanne Dolan <ryannedolan@gmail.com> wrote:
> >
> > > John, I'm glad to learn I'm not the only one who's re-read the metrics
> > > code multiple times.
> > >
> > > I do wonder if the proposed names could be improved further though, given
> > > that "sum", "total", and "count" are roughly synonymous. I'm already
> > > scratching my head at what "TotalSum" means. It's clear in the context of
> > > your matrix, juxtaposed with the alternatives, but when I come across the
> > > name in isolation I suspect I'll be back looking at the implementation
> > > again.
> > >
> > > Ryanne
> > >
> > > On Fri, Jul 12, 2019, 1:45 PM John Roesler <john@confluent.io> wrote:
> > >
> > >> Hi Kafka devs,
> > >>
> > >> Yesterday, I proposed KIP-488 as a minor cleanup of some of our metric
> > >> implementations.
> > >>
> > >> KIP-488: https://cwiki.apache.org/confluence/x/kkAyBw
> > >>
> > >> The change seems pretty uncontroversial, so I'm just going to open the
> > >> vote now.
> > >>
> > >> Feel free to veto or just request more discussion if you disagree with
> > >> the KIP. The vote will remain open for 72 hours.
> > >>
> > >> Thanks,
> > >> -John
> > >>
> > >
> >
>
>
> --
> -- Guozhang

Mime
View raw message