kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Waleed Fateem <waleed.fat...@gmail.com>
Subject Can't build Kafka project
Date Sun, 01 Oct 2017 18:02:23 GMT
Hi everyone,

I'm quite new to Kafka from a development perspective and I'm having some
issues building the project in Eclipse.

I recall being able to do this with the Kafka 0.10.2 source code, but now
I'm having issues with the 0.11 code.

Steps done so far:

- git clone https://github.com/apache/kafka.git

Ran the following from /kafka directory:

- gradle

- ./gradlew jar

- ./gradlew eclipse

I went ahead and imported the project in Eclipse and attempted to build it,
but the 'streams' project is failing to build with the following error:


Project 'streams' is missing required library:
'/Users/waleed/git/apache/kafka/core/build/classes/java/test' streams

Any pointers would be greatly appreciated.

Thank you.

Waleed

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message