kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias J. Sax" <matth...@confluent.io>
Subject Re: [DISCUSS] KIP-120: Cleanup Kafka Streams builder API
Date Tue, 07 Feb 2017 01:40:24 GMT

thanks for your feedback.

I completely agree that KStreamBuilder#merge() is miss placed and should
belong to KStream. However, I wanted to keep this KIP focus on one thing.

As mentioned in a previous reply, we plan to have at least one more KIP
to clean up DSL -- this future KIP should include exact this change.


On 2/6/17 4:26 PM, Gwen Shapira wrote:
> I like the cleanup a lot :)
> The cleaner lines between PAPI and DSL are very helpful to beginners
> who try to make sense of a long list of methods.
> I noticed that the "merge" method is still part of StreamBuilder. I
> thought it belongs inside KStream. Merge seems a lot like the SQL
> "union" operator, so I expect it to be a method of the same object as
> "join". At least, it isn't immediately clear to me why "join" and
> "merge" belong in two different levels of the hierarchy. They both
> transform two (or more) streams into one.
> Gwen
> On Fri, Feb 3, 2017 at 3:33 PM, Matthias J. Sax <matthias@confluent.io> wrote:
>> Hi All,
>> I did prepare a KIP to do some cleanup some of Kafka's Streaming API.
>> Please have a look here:
>> https://cwiki.apache.org/confluence/display/KAFKA/KIP-120%3A+Cleanup+Kafka+Streams+builder+API
>> Looking forward to your feedback!
>> -Matthias

View raw message