kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guozhang Wang (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KAFKA-2993) compression-rate-avg always returns 0 even with compression.type being set
Date Mon, 18 Jan 2016 01:15:39 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-2993?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Guozhang Wang updated KAFKA-2993:
---------------------------------
       Resolution: Fixed
    Fix Version/s: 0.9.0.1
           Status: Resolved  (was: Patch Available)

Issue resolved by pull request 784
[https://github.com/apache/kafka/pull/784]

> compression-rate-avg always returns 0 even with compression.type being set
> --------------------------------------------------------------------------
>
>                 Key: KAFKA-2993
>                 URL: https://issues.apache.org/jira/browse/KAFKA-2993
>             Project: Kafka
>          Issue Type: Bug
>          Components: producer 
>    Affects Versions: 0.9.0.0
>            Reporter: TAO XIAO
>            Assignee: TAO XIAO
>            Priority: Minor
>             Fix For: 0.9.0.1
>
>
> The producer metric compression-rate-avg always returns 0 even with compression.type
set to snappy. I drilled down the code and discovered that the position of bytebuffer in org.apache.kafka.common.record.Compressor
is reset to 0 by RecordAccumulator.drain() before calling metric updates in sender thread.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message