kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sriram Subramanian (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (KAFKA-648) Use uniform convention for naming properties keys
Date Fri, 11 Jan 2013 00:06:13 GMT

     [ https://issues.apache.org/jira/browse/KAFKA-648?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sriram Subramanian updated KAFKA-648:
-------------------------------------

    Attachment: configchanges-v5.patch

40 / 42/ 43
Accepted the suggestions but handled them differently. Specifying max and min at the beginning
will cause configs related to the same feature to not look similar. For Example, 

max.log.Index.size and log.roll.hours are both configs related to logs but end up looking
different. 

Instead, the configs use the following format - 

  ConfigName => ComponentName AnyString [Max/Min] [Unit]

  FeatureName => Name of the  component/feature this config is used for. Example - log,
replica, etc.

  AnyString => A string that represents what this config is used for

  Max/Min => Optional. Used if the config represents a max or min value. For example, replicaLagTimeMaxMs

  Unit => Optional. The unit of the value the config represents. For example, replicaLagMaxBytes
for value specified in bytes.

41 Removed the producer prefix in producer configs. 

John you may have to fix the json files once more to work with the new changes.
                
> Use uniform convention for naming properties keys 
> --------------------------------------------------
>
>                 Key: KAFKA-648
>                 URL: https://issues.apache.org/jira/browse/KAFKA-648
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.8
>            Reporter: Swapnil Ghike
>            Assignee: Sriram Subramanian
>            Priority: Blocker
>             Fix For: 0.8, 0.8.1
>
>         Attachments: configchanges-1.patch, configchanges-v2.patch, configchanges-v3.patch,
configchanges-v4.patch, configchanges-v5.patch
>
>
> Currently, the convention that we seem to use to get a property value in *Config is as
follows:
> val configVal = property.getType("config.val", ...) // dot is used to separate two words
in the key and the first letter of second word is capitalized in configVal.
> We should use similar convention for groupId, consumerId, clientId, correlationId.
> This change will probably be backward non-compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message