kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Fung (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (KAFKA-648) Use uniform convention for naming properties keys
Date Wed, 09 Jan 2013 16:36:12 GMT

    [ https://issues.apache.org/jira/browse/KAFKA-648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13548650#comment-13548650
] 

John Fung commented on KAFKA-648:
---------------------------------

Hi Sriram,

The change in system_test/migration_tool_testsuite/config/migration_consumer.properties is
not needed because the migration tool consumer is using 0.7 library and would not be aware
of this naming convention change.

Other than that, changes in the System Test part looks good.
                
> Use uniform convention for naming properties keys 
> --------------------------------------------------
>
>                 Key: KAFKA-648
>                 URL: https://issues.apache.org/jira/browse/KAFKA-648
>             Project: Kafka
>          Issue Type: Bug
>    Affects Versions: 0.8
>            Reporter: Swapnil Ghike
>            Assignee: Sriram Subramanian
>            Priority: Blocker
>             Fix For: 0.8, 0.8.1
>
>         Attachments: configchanges-1.patch, configchanges-v2.patch, configchanges-v3.patch
>
>
> Currently, the convention that we seem to use to get a property value in *Config is as
follows:
> val configVal = property.getType("config.val", ...) // dot is used to separate two words
in the key and the first letter of second word is capitalized in configVal.
> We should use similar convention for groupId, consumerId, clientId, correlationId.
> This change will probably be backward non-compatible.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message