kafka-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neha Narkhede <neha.narkh...@gmail.com>
Subject Re: patched performance testing issues
Date Sun, 06 Nov 2011 18:46:21 GMT
Joe,

Its a pain that I had to separate the perf patches into separate JIRAs
and have not still checked it in. Sorry for the trouble!

>> Caused by: java.lang.ClassNotFoundException: kafka.tools.ProducerPerformance

Here, the bin/kafka-producer-perf-test.sh is still referring to the
old location of ProducerPerformance. By applying kafka-175's patch,
this will get resolved.

>> > Joseph-Steins-MacBook-Air:kafka joestein$ patch -p0 -i ~/kafka-175.patch
> patching file perf/config/log4j.properties
> patching file perf/bin/consumer-throughput-over-fetch-size.sh
> patch: **** malformed patch at line 82:

That patch seems to have some malformed lines. I've uploaded an
updated patch -
https://issues.apache.org/jira/secure/attachment/12502678/kafka-175-updated.patch

Thanks,
Neha


On Sun, Nov 6, 2011 at 9:46 AM, Joe Stein <cryptcom@gmail.com> wrote:
> Hi, I applied kafka-176.patch and got an error while trying to run it
>
> Joseph-Steins-MacBook-Air:kafka joestein$ bin/kafka-producer-perf-test.sh
> Exception in thread "main" java.lang.NoClassDefFoundError:
> kafka/tools/ProducerPerformance
> Caused by: java.lang.ClassNotFoundException: kafka.tools.ProducerPerformance
> at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
> at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
>
> I then grabbed kafka-175 and got an error while applying the patch
>
> Joseph-Steins-MacBook-Air:kafka joestein$ patch -p0 -i ~/kafka-175.patch
> patching file perf/config/log4j.properties
> patching file perf/bin/consumer-throughput-over-fetch-size.sh
> patch: **** malformed patch at line 82:
>
> Should I be patching in some specific order or different commands or
> something else I am doing wrong?  Let me know please
>
>
> /*
> Joe Stein
> http://www.linkedin.com/in/charmalloc
> Twitter: @allthingshadoop <http://www.twitter.com/allthingshadoop>
> */
>

Mime
View raw message