jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Turli <andrea.tu...@gmail.com>
Subject Re: Issue with jclouds computeService listNodes() ?
Date Thu, 21 Jun 2018 07:40:46 GMT
Archana,

interesting!

To debug this, I would attach a IAM role with e.g the AmazonEC2FullAccess
policy set and re-test. If that works, I'll then try to play with more
restricting policies, in case you don't like AmazonEC2FullAccess in
production.

Best,
Andrea

On Thu, Jun 21, 2018 at 9:34 AM archieprad@gmail.com <archieprad@gmail.com>
wrote:

> Hi Andrea,
> I tried the two methods that you suggested and neither of them work. I
> also tried another method listHardwareProfiles() and it works. Is there
> some different level of authentication required across these? Please do let
> me know what you think.
>
> Cheers
> Archana
>
> On 2018/06/20 07:26:44, Andrea Turli <andrea.turli@gmail.com> wrote:
> > Hi Archana,
> >
> > I don't see any particular reason listNodes  would behave differently
> when
> > using IAM role vs Access Key and Secret Key - Once the Ec2Api is
> configured
> > to use org.jclouds.aws.domain.SessionCredentials everything should just
> > work.
> >
> > Is listNodes the only failing one? Can you share the stacktrace of a
> > failing call?
> > Could you double check listAssignableLocations() or listImages() with the
> > same IAM role? if they work, can it be related to weird IAM permissions?
> >
> > HTH,
> > Andrea
> >
> > On Wed, Jun 20, 2018 at 8:01 AM archieprad@gmail.com <
> archieprad@gmail.com>
> > wrote:
> >
> > > Hi All,
> > > I am trying to SSH from one EC2 instance into another using netflix's
> > > simian army. I am using IAM role instead of Access key and Secret key.
> > > Wondering if there is an issue with calling listNodes() when using IAM
> > > role. Any insight on this, or any workaround on the issue is helpful.
> > >
> > > Cheers
> > > Archana
> > >
> >
>

Mime
View raw message