jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paya, Ashkan" <Ashkan.P...@dell.com>
Subject Swift in jclouds 2.0.0
Date Thu, 05 Jan 2017 19:49:49 GMT
Hi,

According to JCLOUDS-786<https://issues.apache.org/jira/browse/JCLOUDS-786>, the old
swift api is no longer supported in jclouds 2.0.0. Does this mean that we should just change
the provider’s name from swift to openstack-swift? In my case, solely changing the name
does not seem to resolve the issue. When I run the my command using openstack-swift provider
and the endpoint ending in /auth/, I get the following error:

  *    [main] DEBUG o.j.rest.internal.InvokeHttpMethod - >> invoking AuthenticationApi.authenticateWithTenantNameAndCredentials
  *    [main] DEBUG o.j.h.i.JavaUrlHttpCommandExecutorService - Sending request -311723242:
POST http://XXXXX/auth/tokens HTTP/1.1
  *    [main] DEBUG jclouds.wire - >> "Sensitive data in payload, use jclouds.wire.log.sensitive
override to enable logging this data."
  *    [main] DEBUG jclouds.headers - >> POST http://XXXXX/auth/tokens HTTP/1.1
  *    [main] DEBUG jclouds.headers - >> Accept: application/json
  *    [main] DEBUG jclouds.headers - >> Content-Type: application/json
  *    [main] DEBUG jclouds.headers - >> Content-Length: 96
  *    [main] DEBUG o.j.h.i.JavaUrlHttpCommandExecutorService - Receiving response -311723242:
HTTP/1.1 400 Bad Request
  *    [main] DEBUG jclouds.headers - << HTTP/1.1 400 Bad Request
  *    [main] DEBUG jclouds.headers - << Connection: keep-alive
  *    [main] DEBUG jclouds.headers - << X-Trans-Id: tx1299bf0f2fb345699f466-00586ea027
  *    [main] DEBUG jclouds.headers - << Date: Thu, 05 Jan 2017 19:36:07 GMT
  *    [main] DEBUG jclouds.headers - << Content-Type: text/html; charset=UTF-8
  *    [main] DEBUG jclouds.headers - << Content-Length: 137
  *    [main] DEBUG jclouds.wire - << "<html><h1>Bad Request</h1><p>The
server could not comply with the request since it is either malformed or otherwise incorrect.</p></html>”

Is there any other tweaks required to resolve this issue?

Sincerely,
Ashkan
Mime
View raw message