jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apoorva Deshpande <apoor...@tintri.com>
Subject Re: novaApi.getKeyPairApi() for Openstack Liberty
Date Tue, 26 Apr 2016 17:15:59 GMT
Recently I encountered similar error  [1] but 2.0.0-SNAPSHOT jar fixed it for me.
You can follow the email thread for more information. It also mentions what could have possibly
fixed it in 2.0.0-SNAPSHOT.


From: Kai Liu <kliu.gis@gmail.com<mailto:kliu.gis@gmail.com>>
Reply-To: "user@jclouds.apache.org<mailto:user@jclouds.apache.org>" <user@jclouds.apache.org<mailto:user@jclouds.apache.org>>
Date: Tuesday, April 26, 2016 at 10:11 AM
To: "user@jclouds.apache.org<mailto:user@jclouds.apache.org>" <user@jclouds.apache.org<mailto:user@jclouds.apache.org>>
Subject: novaApi.getKeyPairApi() for Openstack Liberty


I was wondering if anyone is using Openstack Liberty. I am using jclouds (2.0.0-snapshot)
and tried to get KeyPairApi using the following code:

            try {
Optional<KeyPairApi> keyapi = api.getKeyPairApi(region);
KeyPairApi keyPairApi = keyapi.get();
} catch (Exception e) {

The following error occurs:

java.lang.IllegalStateException: Optional.get() cannot be called on an absent value

But the codes works for Openstack Kilo. Any help would be greatly appreciated

Best regards,


Kai Liu

Ph.D. student
Department of Geography and GeoInformation Science
George Mason University
View raw message