jclouds-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cen <imba...@gmail.com>
Subject Re: Group name not set for new nodes on EC2
Date Wed, 16 Mar 2016 17:15:43 GMT
Thank you.

I have already solved the security group issue. The problem was the
"cosmetic" one I mentioned in the email on the end. I was creating a
group with name "crossbuild" and tried to use the same name when
creating the node. The exception was thrown when creating the node, not
when creating the group. After changing the group name in template to
"jclouds#crossbuild" it started working.


On 16. 03. 2016 18:12, Ignasi Barrera wrote:
> Hi Cen,
> 
> I'll have a look at this and the security group thing later today.
> 
> Apologies for the late reply!
> 
> I.
> 
> Hi
> 
> For some reason the new nodes I create on EC2 are missing the group names.
> 
> NodeMetadata node =
> getOnlyElement(compute.createNodesInGroup(vmSettings.getGroupName(), 1,
> template));
> logger.info <http://logger.info>("New node " + node.getId() + " " +
> concat(node.getPrivateAddresses(), node.getPublicAddresses())+" in group
> "+vmSettings.getGroupName());
> ...
> upload some files and run some script on the node
> ...
> logger.info <http://logger.info>("Node in group "+node.getGroup()+"
> initiallized.");
> 
> 
> Output:
> New node eu-central-1/i-1ff660a3 [ip redacted, ip redacted] in group
> crossbuild-ami-87564feb
> Node in group null initiallized.
> 
> 
> And indeed the group tag is missing in EC2 console. I hardly believe
> such basic functionality would be a bug in Jclouds but I also can't see
> what I am doing wrong. Any ideas?

Mime
View raw message