incubator-photark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Donie <steve.do...@gmail.com>
Subject Re: first impressions
Date Mon, 28 Sep 2009 20:23:38 GMT
Just updated and build and deployed and all is working now - excellent. Now
to start hacking on it!
My current photo album is 99% static html, all generated by a huge nasty
perl program I started a long time ago and still hack at now and then. I've
been thinking about doing something different with it, and started looking
at Spring Roo recently. This is one more thing to look at and play with. I
like the direction you seem to be going.

Steve
http://donie.us/

On Mon, Sep 28, 2009 at 2:43 PM, Luciano Resende <luckbr1975@gmail.com>wrote:

> On Mon, Sep 28, 2009 at 11:28 AM, Steve Donie <steve@donie.us> wrote:
> > Hey all - just wanted to say congrats on the M1 release. a few first
>
> Thank you
>
> > impressions and a question:
> > I followed the instructions at
> > http://incubator.apache.org/photark/getting-started.html, mainly
> checking
> > out trunk from svn, mvn clean install, and then deploying the webapp war
> to
> > Tomcat 5.528 on my machine.
> >
> > The first issue is documentation related - the site says
> >
> > *Deploying PhotArk in Web Application*
> >
> > After building the source code, deploy
> > photo-gallery-webapp/target/photo-gallery-webapp.war in your favorite web
> > application server (e.g Apache Tomcat)
> >
>
> The getting started guide is still based on M1-incubating release, and
> trunk has been updated with some changes which I plan to get stable
> and then update the guide to reflect these changes.... I should be
> doing the doc updates soon.
>
> > Point your browser to : http://localhost:8080/photo-gallery-webapp/
> >
> > The source code seems to have been refactored - I deployed
> > photark-webapp/target/photark.war
> >
> > My bigger problem - the web app won't start.
> >
> > I'm not sure what the problem is - I get this in my catalina log file:
> >
> > Sep 28, 2009 1:09:28 PM
> org.apache.tuscany.sca.host.webapp.WebAppServletHost
> > initContextPath
> > INFO: ContextPath: /photark
> > Sep 28, 2009 1:09:28 PM org.apache.tuscany.sca.node.impl.NodeImpl <init>
> > INFO: Creating node: null
> > Sep 28, 2009 1:09:28 PM org.apache.catalina.core.StandardContext start
> > SEVERE: Error filterStart
> > Sep 28, 2009 1:09:28 PM org.apache.catalina.core.StandardContext start
> > SEVERE: Context [/photark] startup failed due to previous errors
> >
> > I also noticed a small deploy problem in that servlet-api-2.4.jar is
> being
> > included in the war file - that dependency should be marked as compile
> time
> > rather than run time.
> >
>
> I have just committed some changes I made over the weekend, which
> should fix all these issues. Would you give it a try on the latest
> trunk code (svn r819689) ?
>
>
> --
> Luciano Resende
> http://people.apache.org/~lresende
> http://lresende.blogspot.com/
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message