incubator-photark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Donie <st...@donie.us>
Subject first impressions
Date Mon, 28 Sep 2009 18:28:05 GMT
Hey all - just wanted to say congrats on the M1 release. a few first
impressions and a question:
I followed the instructions at
http://incubator.apache.org/photark/getting-started.html, mainly checking
out trunk from svn, mvn clean install, and then deploying the webapp war to
Tomcat 5.528 on my machine.

The first issue is documentation related - the site says

*Deploying PhotArk in Web Application*

After building the source code, deploy
photo-gallery-webapp/target/photo-gallery-webapp.war in your favorite web
application server (e.g Apache Tomcat)

Point your browser to : http://localhost:8080/photo-gallery-webapp/

The source code seems to have been refactored - I deployed
photark-webapp/target/photark.war

My bigger problem - the web app won't start.

I'm not sure what the problem is - I get this in my catalina log file:

Sep 28, 2009 1:09:28 PM org.apache.tuscany.sca.host.webapp.WebAppServletHost
initContextPath
INFO: ContextPath: /photark
Sep 28, 2009 1:09:28 PM org.apache.tuscany.sca.node.impl.NodeImpl <init>
INFO: Creating node: null
Sep 28, 2009 1:09:28 PM org.apache.catalina.core.StandardContext start
SEVERE: Error filterStart
Sep 28, 2009 1:09:28 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/photark] startup failed due to previous errors

I also noticed a small deploy problem in that servlet-api-2.4.jar is being
included in the war file - that dependency should be marked as compile time
rather than run time.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message