incubator-photark-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luciano Resende <luckbr1...@gmail.com>
Subject Re: PhotArk: SCADomain.js missing
Date Mon, 28 Sep 2009 19:46:08 GMT
On Sun, Sep 27, 2009 at 10:49 PM, Luciano Resende <luckbr1975@gmail.com> wrote:
> On Sun, Sep 27, 2009 at 8:51 PM, thilanka geeganage
> <lgtkaushalya@yahoo.com> wrote:
>> Hi,
>> I tried to download, build and run the PhotArk gallery by following the exact instructions
in http://incubator.apache.org/photark/getting-started.html. However, it seems the compiled
version does not have a SCADomain.js file so the javascript cannot be run. I tried to find
the SCADomain.js in the internet but failed.
>> Would the addition of a SCADomain.js file fix the error? Can anyone please send the
file? I'm kind of urgent because I'm going to add some functionality to the project as an
undergraduate assignment and the deadline for the proposal is tomorrow (29th).
>> Thanks and regards,Thilanka
>>
>
> Your best choice would be to get the PhotArk war from the
> M1-incubating release [1], or if you want to build the code from SVN,
> use the M1 branch [2]. As for the SCADomain.js, this file is generated
> by the Tuscany runtime... if this is not being generated, you might
> have missed some dependencies on your application (please see PhotArk
> war in the binary distribution and check the necessary dependencies on
> WEB-INF\lib)
>

I have brought up the photArk-webapp module to comply with the latest
updates on the services, and the photArk webapp gallery from trunk
should be working again. Please give it a try and let me know if you
still have issues.

-- 
Luciano Resende
http://people.apache.org/~lresende
http://lresende.blogspot.com/

Mime
View raw message