That runs fine. No errors.

On Fri, Apr 29, 2016 at 2:45 PM, Igor Sapego <isapego@gridgain.com> wrote:
Murthi,

What about ignite.exe file from the %IGNITE_HOME%/platforms/cpp/project/vs/$(Platform)/$(Configuration)?
Are you able to run it? Does it give you the same error?

Best Regards,
Igor

On Fri, Apr 29, 2016 at 9:07 PM, Murthy Kakarlamudi <ksatya@gmail.com> wrote:
These are the steps I have taken:

2. Updated my IGNITE_HOME variable to point to 1.6
Inline image 5
3. Opened  ignite.sln in apache-ignite-fabric-1.6.0-SNAPSHOT-bin\platforms\cpp\project\vs folder and built the solution.
4. In my sample c++ solution I have the below settings at the project level
Inline image 3
Inline image 4

Below is my Cache Config:
       xsi:schemaLocation="
    <bean id="grid.cfg" class="org.apache.ignite.configuration.IgniteConfiguration">
        <!-- Set to true to enable distributed class loading for examples, default is false. -->
        
<property name="clientMode" value="true"/>
        <property name="cacheConfiguration">
            <list>
                <!--
                    Partitioned cache example configuration with binary objects enabled.
                    Used in .NET example that is available only in enterprise edition.
                -->
                <bean class="org.apache.ignite.configuration.CacheConfiguration">
<property name="atomicityMode" value="ATOMIC"/>
                    <property name="backups" value="1"/>
                </bean>

                <!--
                    Partitioned cache example configuration.
                    Used in .NET cache store example that is available only in enterprise edition.
                -->
<!--
                <bean class="org.apache.ignite.configuration.CacheConfiguration">
                    <property name="name" value="tx"/>
                    <property name="atomicityMode" value="TRANSACTIONAL"/>
                    <property name="backups" value="1"/>
                </bean>
-->
            </list>
        </property>

        <!-- Explicitly configure TCP discovery SPI to provide list of initial nodes. -->
        <property name="discoverySpi">
            <bean class="org.apache.ignite.spi.discovery.tcp.TcpDiscoverySpi">
                <property name="ipFinder">
                    <!--
                        Ignite provides several options for automatic discovery that can be used
                        instead os static IP based discovery.
                    -->
                    <!-- Uncomment static IP finder to enable static-based discovery of initial nodes. -->
                    <bean class="org.apache.ignite.spi.discovery.tcp.ipfinder.vm.TcpDiscoveryVmIpFinder">
                    <!-- <bean class="org.apache.ignite.spi.discovery.tcp.ipfinder.multicast.TcpDiscoveryMulticastIpFinder"> -->
                        <property name="addresses">
                            <list>
                                <!-- In distributed environment, replace with actual host IP address. -->
                                <value>127.0.0.1:47500..47501</value>
                            </list>
                        </property>
                    </bean>
                </property>
            </bean>
        </property>
    </bean>
</beans>

On Fri, Apr 29, 2016 at 1:44 PM, Igor Sapego <isapego@gridgain.com> wrote:
It seems like you are trying to use client node binary from Ignite 1.5 for
Ignite 1.6. You should build client node binary for the 1.6 instead to use
with Ignite 1.6 as they are not cross-compatible.

Best Regards,
Igor

On Fri, Apr 29, 2016 at 8:39 PM, Igor Sapego <isapego@gridgain.com> wrote:
Hi,

Where have you got your C++ client node binary from?

Best Regards,
Igor

On Fri, Apr 29, 2016 at 8:32 PM, Murthy Kakarlamudi <ksatya@gmail.com> wrote:
Hi All,
    I downloaded the latest 1.6 binary from latest builds. I am trying to start a node from c++ and getting the below error.

An error occurred: Failed to initialize JVM [errCls=java.lang.NoSuchMethodError, errMsg=executeNative]

The same c++  node starts fine if I point my IGNITE_HOME to 1.5 instead of 1.6.

Any help is much appreciated...

Thanks.