hudi-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinoth Chandar <vin...@apache.org>
Subject Re: Upsert after Delete
Date Thu, 22 Aug 2019 19:38:02 GMT
That’s interesting. Can you also share details on storage type and how you
are issuing the deletes and also the table/view (ro, rt) that you are
querying?

On Thu, Aug 22, 2019 at 9:49 AM Kabeer Ahmed <kabeer@linuxmail.org> wrote:

> Hudi experts and Users,
>
> Has anyone attempted an upsert after a delete? Here is a weird thing that
> I have bumped into and it is a shame that this has come up when someone in
> the team tested this whilst I failed to run this test.
> Use case:
> Insert data into a table. Say records (1, kabeer | 2, vinoth)
>
> Delete a record (1, kabeer). Data in the table is: (2, vinoth) and it is
> visible via sql through Presto/Hive.
>
> Upsert a new record into the same table (3, balaji). Query the table and
> only record that is visible is: (3, balaji). The record (2, vinoth) is not
> displayed in the results.
>
> Any ideas on what could be at play here? Has someone done upsert after
> delete?
>
> Thanks,
> Kabeer
>
> PS: Please note that upsert functionality is well tested and if we do (1,
> vinoth) insert followed by upsert of (2, balaji) both the records are
> visible. So something else is at play and would appreciate any help that
> you experts can provide insight.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message