hc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "shyam sundar g (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HTTPCLIENT-891) java.net.SocketException: Unconnected sockets not implemented thrown
Date Mon, 16 Nov 2009 23:17:39 GMT

    [ https://issues.apache.org/jira/browse/HTTPCLIENT-891?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12778638#action_12778638

shyam sundar g commented on HTTPCLIENT-891:

Hi,I used HTTPPost method to connect to the server and it was working.
So we decided to migrate to HTTPClient 4.0 now.

I have a doubt here.How to mention the target path in the destination server 
where the file uploaded should be saved.

In HTTPClient 3.1 the target path can be mentioned in MultiPartPost constructor method but
in HTTPCLient 4 this class is removed.

Can i use MultiPartEntity object to mention the target path

Thankls for the support.


> java.net.SocketException: Unconnected sockets not implemented thrown
> --------------------------------------------------------------------
>                 Key: HTTPCLIENT-891
>                 URL: https://issues.apache.org/jira/browse/HTTPCLIENT-891
>             Project: HttpComponents HttpClient
>          Issue Type: Bug
>          Components: HttpClient
>    Affects Versions: 4.0 Final
>         Environment: Application Server : Websphere application server
> Java : JDK
>            Reporter: shyam sundar g
>             Fix For: 4.0 Final
>   Original Estimate: 0h
>  Remaining Estimate: 0h
> Iam using HTTPClient 4.0 to connect a remote server and transfer file using HTTPS.
> When i tried to connect i get the exception "java.net.SocketException: Unconnected sockets
not implemented".
> Please look at the stack trace
> java.net.SocketException: Unconnected sockets not implemented
> 	at java.lang.Throwable.<init>(Throwable.java:196)
> 	at java.lang.Exception.<init>(Exception.java:41)
> 	at java.io.IOException.<init>(IOException.java:40)
> 	at java.net.SocketException.<init>(SocketException.java:29)
> 	at javax.net.SocketFactory.createSocket(SocketFactory.java:2)
> 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
> 	at java.lang.reflect.Method.invoke(Method.java:585)
> 	at org.apache.commons.httpclient.protocol.ReflectionSocketFactory.createSocket(Unknown
> 	at org.apache.commons.httpclient.protocol.SSLProtocolSocketFactory.createSocket(Unknown
> 	at org.apache.commons.httpclient.HttpConnection.open(Unknown Source)
> 	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(Unknown Source)
> 	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(Unknown Source)
> 	at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
> 	at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
> 	at co.com.personalsoft.ftpseguro.utilidades.TransmisionHTTP.ejecutarTransmisionHTTP(TransmisionHTTP.java:107)
> 	at co.com.personalsoft.ftpseguro.utilidades.TransmisionFTPNew.ejecutarTransmisionAuto(TransmisionFTPNew.java:483)
> 	at co.com.personalsoft.ftpseguro.utilidades.TransmisionFTPNew.ejecutarTransmision(TransmisionFTPNew.java:1016)
> 	at co.com.personalsoft.ftpautomatico.ConexionThread.run(ConexionThread.java:58)
> 	at java.lang.Thread.run(Thread.java:595)
> The same error is found while using HTTP Client 3.1.
> Kindly help to solve this problem as the production deployment is delayed because of
this error.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org

View raw message