hbase-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Marc Spaggiari <jean-m...@spaggiari.org>
Subject Re: Re: While starting 3-nodes cluster hbase: WARN org.apache.zookeeper.ClientCnxn: Session 0x0 for server null
Date Thu, 25 Apr 2013 12:43:50 GMT
Hi John,

bin/start-dfs is to start hadoop, right? Why are you trying to start
that from HBase Master? You said that you hadoop is already configured
and working fine. You should start HBase with bin/start-hbase.sh which
will start the master and the regionservers.

Also, in your host file, please replace "    debian01" by the
real IP. It will help.

Keep us posted.


2013/4/24 John Foxinhead <john.foxinhead@gmail.com>:
> I tried this way: I started hadoop, and it's all ok, so go on.
> I setted HBASE_MANAGES_ZK=false, so i could start zookeeper, try it and
> check the problem.
> I changed the zookeeper.quorum to jobtracker,datanode1 instead of
> zookeeper1,zookeeper2 because the IP are the same, but in log file the
> hostname reported was jobtracker and datanode1, while in zookeeper.quorum i
> setted zookeper1,zookeeper2 so i changed this property because in hbase
> documentation it's recommended to set the same hostname specified in log
> file otherwise zookeeper nodes could not recognise themselves as zookeeper
> nodes and maybe master could have problem logging. Anyway, I made this
> change in all the nodes.
> I start zookeeper in zookeeper nodes, and it works now because when i log
> with bin/hbase zkcli from master node (who is not running zookeeper) It
> logs at datanode1:2181 (where zookeeper is running) and commands like "ls
> /" work.
> When i use from master /bin/start-dfs the only output is "starting
> master...". When I see log file i noticed that master send a zookeeper
> request to and accept response from, while using
> bin/hbase zkcli it connect with datanode1.2181. This is very strange, I
> think. What could be the reason why?

View raw message