deltacloud-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Lutterkort <lut...@redhat.com>
Subject Re: [PATCH core 1/5] CIMI: Added 'should_properly_serialize_model' helper to RSpec tests
Date Thu, 24 Nov 2011 00:34:18 GMT
On Wed, 2011-11-23 at 17:23 +0100, mfojtik@redhat.com wrote:
> From: Michal Fojtik <mfojtik@redhat.com>
> 
> 
> Signed-off-by: Michal fojtik <mfojtik@redhat.com>
> ---
>  server/spec/cimi/model/machine_admin_spec.rb       |   14 ++------------
>  .../spec/cimi/model/machine_configuration_spec.rb  |   12 ++----------
>  server/spec/cimi/model/machine_image_spec.rb       |   11 ++---------
>  server/spec/cimi/model/machine_spec.rb             |   17 ++---------------
>  server/spec/cimi/model/machine_template_spec.rb    |   12 ++----------
>  server/spec/cimi/model/volume_spec.rb              |   12 ++----------
>  server/spec/spec_helper.rb                         |   15 +++++++--------
>  7 files changed, 19 insertions(+), 74 deletions(-)

This gives me a bunch of spec failures since should_serialize_from_json!
and should_serialize_from_xml! are still used in some specs.

ACK after updating those specs.

Incidentally, on my Fedora 15 machine, I also run into trouble with the
Gemfile:

        source "http://rubygems.org"
        
        gemspec
        
        group :development do
          gem 'ruby-debug', :platforms => :mri_18
          gem 'ruby-debug19', :platforms => :mri_19, :require => 'ruby-debug'
          gem "compass", ">= 0.8.17"
          gem "vcr"
          gem "webmock"
          gem "rack-test", ">= 0.5.3"
          gem "ci_reporter"
          gem "cucumber", ">= 0.6.3"
          gem "rcov", ">= 0.9.8"
          gem "rspec", "~> 2.0.0"
        end

This fails in two places: (1) ruby-debug19 is not found (it shouldn't
look for it since I am on mri_18, but who knows); is there a good reason
why we even mention ruby-debug in the Gemfile ? FWIW, you can do
development perfectly fine without a debugger installed. (2) no rspec ~>
2.0.0; I have 2.7.0. Is there a good reason why we can't just require
rspec >= 2.0.0 ?

TL;DR: can we commit this patch (and whoever ACK's this should just
commit it):

diff --git a/server/Gemfile b/server/Gemfile
index f453f4a..b3180e3 100644
--- a/server/Gemfile
+++ b/server/Gemfile
@@ -3,8 +3,6 @@ source "http://rubygems.org"
 gemspec
 
 group :development do
-  gem 'ruby-debug', :platforms => :mri_18
-  gem 'ruby-debug19', :platforms => :mri_19, :require => 'ruby-debug'
   gem "compass", ">= 0.8.17"
   gem "vcr"
   gem "webmock"
@@ -12,6 +10,6 @@ group :development do
   gem "ci_reporter"
   gem "cucumber", ">= 0.6.3"
   gem "rcov", ">= 0.9.8"
-  gem "rspec", "~> 2.0.0"
+  gem "rspec", ">= 2.0.0"
 end

David



Mime
View raw message