datafu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eyal Allweil via Review Board <nore...@reviews.apache.org>
Subject Re: Review Request 73145: DATAFU-157 Add support for newer versions of Gradle
Date Fri, 15 Jan 2021 15:57:37 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/73145/#review222478
-----------------------------------------------------------


Ship it!




Ship It!

- Eyal Allweil


On Jan. 15, 2021, 1:14 a.m., Venkatasubrahmanian Narayanan wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/73145/
> -----------------------------------------------------------
> 
> (Updated Jan. 15, 2021, 1:14 a.m.)
> 
> 
> Review request for DataFu.
> 
> 
> Bugs: DATAFU-156
>     https://issues.apache.org/jira/browse/DATAFU-156
> 
> 
> Repository: datafu
> 
> 
> Description
> -------
> 
> DataFu is incompatible with Gradle 5 and later due to API changes on Gradle's side. This
patch brings the autojar code and the specification of the build files in line with Gradle
7 standards.
> 
> 
> Diffs
> -----
> 
>   buildSrc/build.gradle 02c21af 
>   buildSrc/src/main/groovy/datafu/autojar/task/Autojar.groovy a620337 
> 
> 
> Diff: https://reviews.apache.org/r/73145/diff/1/
> 
> 
> Testing
> -------
> 
> Built DataFu on Mac OS with Gradle 6.8(where the bug https://issues.apache.org/jira/browse/DATAFU-156
is reproducible), and tested with Pig.
> 
> 
> Thanks,
> 
> Venkatasubrahmanian Narayanan
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message