datafu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eyal Allweil (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DATAFU-125) Upgrade Gradle to v4 or later
Date Fri, 20 Oct 2017 13:59:00 GMT

     [ https://issues.apache.org/jira/browse/DATAFU-125?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eyal Allweil updated DATAFU-125:
--------------------------------
    Attachment: DATAFU-125.patch

This updates Gradle to 3.5.1. It seems to me that gradle-autojar doesn't work in Gradle 4,
which is why I settled for an older version.

While running _gradlew clean assemble_ I get this warning message:

{{:datafu-pig:jarWithDependencies
Manifest.writeTo(Writer) has been deprecated and is scheduled to be removed in Gradle 4.0.
Please use Manifest.writeTo(Object) instead.
}}

And the build indeed fails in Gradle 4.

However, this update is enough to let us merge DATAFU-118, and it is a far newer version.
I ran _assemble_ and _test_ on it; I still want to run a Pig script using the assembled jar
but I'll do that next week.

What other tasks do we want to check to see that this fix is valid? Or do we want to try to
get Gradle 4 working?

> Upgrade Gradle to v4 or later
> -----------------------------
>
>                 Key: DATAFU-125
>                 URL: https://issues.apache.org/jira/browse/DATAFU-125
>             Project: DataFu
>          Issue Type: Task
>            Reporter: Matthew Hayes
>         Attachments: DATAFU-125.patch
>
>
> We should update to the most recent version of Gradle.  We're currently using 2.4.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message