couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joan Touzet <woh...@apache.org>
Subject Re: installing couchdb on ubuntu 19.04
Date Mon, 22 Jul 2019 04:03:26 GMT
On 2019-07-21 22:39, Rene Veerman wrote:
> root@crow:~# apt install couchdb
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
> 
> The following packages have unmet dependencies:
>  couchdb : Depends: libicu60 (>= 60.1-1~) but it is not installable

This means that libicu in 19.* is not compatible.

>            Recommends: python3-progressbar but it is not going to be
> installed
> E: Unable to correct problems, you have held broken packages.
> 
> ------
> 
> that's the current status, listed above here..
> 
> at first it complained about 2 packages missing, libicu and libssl.
> 
> so i installed the 18.04 *.deb packages for libicu60 (
> https://ubuntu.pkgs.org/18.04/ubuntu-main-i386/libicu60_60.2-3ubuntu3_i386.deb.html)
> and libssl1.0.0 (
> https://ubuntu.pkgs.org/18.04/ubuntu-main-amd64/libssl1.0.0_1.0.2n-1ubuntu5_amd64.deb.html)
> 
> but i'm still stuck at getting libicu's cooperation..

We only publish packages against LTS releases of Debian, Ubuntu, RHEL
and CentOS. That unfortunately doesn't include 19.*. (Yes, I am behind
getting a Debian Buster set of packages up.)

You may be able to get this to work, but you'll need to go consult with
an Ubuntu expert on this - I haven't the time to help you sort this out,
sorry. :(

-Joan


Mime
View raw message