couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Wissel <step...@wissel.net>
Subject Database missing from Fauxton
Date Sun, 05 Feb 2017 13:12:49 GMT
Hi there,

I used curl to replicate a database to Couch2 on a Mac posting this payload
to localhost... :
{
"target": "mydb",
"source": {
"url": "https://someserver/mydb"
},
"connection_timeout": 60000,
"user_ctx": {
"name": "stw",
"roles": ["_admin"]
},
"create_target" : true
}

Worked like a charm.... except the database doesn't show up in Fauxton and
can't be addressed from a URL. I tried again without create_target and it
replicates without an error - so database exists.

I checked: the database file mydb.couch got created in
~/Library/Application Support/CouchDB2/var/lib/couchdb but nothing in the
shards directory

When I use Fauxton to create a database manually (e.g. otherdb), the file
shows up in
~/Library/Application Support/CouchDB2/var/lib/couchdb/shards/[shardnumber]
but not the couchdb directory. Also when I swap mydb with otherdb and try
to replicate (without create_target=true) I get the error "Database not
found".

What do I miss here?
-- 
Mobile message, pegged on glass.

Best regards
Stephan H. Wissel
http://www.wissel.net/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message