couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From max <>
Subject Ubuntu 16.04 Couchdb 1.6.1 fresj install
Date Mon, 13 Feb 2017 09:59:22 GMT

I just installed Couchdb 1.6.1 from apt on Ubuntu 16.04 but I'm stucksince
I changed the port to make CouchDB listen on port 80.
I already faced this problem on Ubuntu 12.04 with an install from source
and I just replaced the user in /usr/local/etc/default/couchdb :
But with this apt install I tough just editing /etc/init/couchdb.conf and
change exec su couchdb -c /usr/bin/couchdb  TO exec su root -c
/usr/bin/couchdb  will make it but it did not.
The error I got when I run "sudo couchdb" is

Apache CouchDB 1.6.1 (LogLevel=info) is starting.
Apache CouchDB has started. Time to relax.
[info] [<0.33.0>] Apache CouchDB has started on
[error] [<0.33.0>] Failed to write to URI file /run/couchdb/couch.uri: no
such file or directory
[error] [<0.32.0>] {error_report,<0.32.0>,
{"init terminating in

So I tried to create the couch.uri file and then I could start couchdb on
port 80 but only with the command "sudo couchdb". The service "sudo
systemctl restart couchdb" is not able to start couchdb and when I try it
the couch.uri is deleted and so one... How to fix this properly ? I know I
could rewrite port 80 to 5984 using apache2 or nginx but I want to figure
out what is going on and I'd like to make it work.

Thanks for any hints.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message