couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Tisdall <>
Subject problems with etc/init.d/couchdb script
Date Thu, 10 May 2012 18:46:21 GMT
I've tried doing lots of Google searches for an answer to this, but I
haven't been successful...

I've installed Couchdb 1.2 from source on Debian 6.  I configured it
with *--localstatedir=/var
--sysconfdir=/etc . Everything seems to be installed correctly.*
*If I run couchdb from the command prompt it seems to run correctly and I'm
able to hit the port with curl and get *{"couchdb":"Welcome","version":"1.2.0"}
successfully. If I run it as "couchdb -b" it also works properly.

Now, the problem... if I try to run things using /etc/init.d/couchdb it
doesn't seem to work properly. I don't get any error messages but the curl
request returns "couldn't connect to host". Also, there seems to be a
process running under the couchdb user id, but it's not the same process
number as what's found in /var/run/couchdb/ ps reports it as
"/bin/sh -e /usr/local/bin/couchdb -a /etc/couchdb/default.ini -a
/etc/couchdb/local.ini -b -r 5 -p /var/run/couchdb/ -o /dev/null
-e /dev/null -R" but there's no response using curl.

Anyone have any ideas how to track down the problem? I don't see any errors
in the logs.

I've tried redirecting the STDERR to /dev/log/couchdb/stderr.log but get
the error "Starting database server: couchdbApache CouchDB needs write
permission on the STDERR file: /dev/log/couchdb/stderr.log" despite giving
it full write permissions.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message