couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Candler <>
Subject Re: Running couchdb on ubuntu 8.04 LTS
Date Tue, 03 Nov 2009 09:08:45 GMT
On Sun, Nov 01, 2009 at 09:51:00PM +0100, Jens wrote:
> I just tried to install couchdb on ubuntu 8.04.

I have it working just fine under Hardy. You need to:

(1) Install erlang using the packages from Jaunty (probably Karmic would
work, I haven't tried it myself). Follow the instructions at
but using "jaunty" instead of "intrepid"

Remember to switch your sources back to hardy after installing erlang!!

(2) Build couchdb from source following exactly the instructions in the
README file. In summary these are:

    [the following as root]
    apt-get install automake autoconf libtool help2man
    apt-get install build-essential erlang libicu-dev libmozjs-dev libcurl4-openssl-dev

    [the following as a normal user, inside your svn checkout directory]
    sudo make install

    [all the following as root]
    adduser --system --home /usr/local/var/lib/couchdb --no-create-home \
            --shell /bin/bash --group --gecos "CouchDB Administrator" couchdb

    chown -R couchdb:couchdb /usr/local/etc/couchdb
    chown -R couchdb:couchdb /usr/local/var/lib/couchdb
    chown -R couchdb:couchdb /usr/local/var/log/couchdb
    chown -R couchdb:couchdb /usr/local/var/run/couchdb

    chmod -R 0770 /usr/local/etc/couchdb
    chmod -R 0770 /usr/local/var/lib/couchdb
    chmod -R 0770 /usr/local/var/log/couchdb
    chmod -R 0770 /usr/local/var/run/couchdb

Then /usr/local/etc/init.d/couchdb start should get you running.

The only thing to watch out for is that you don't have both 0.9.x and 0.10.x
versions installed at the same time, because the erlang library loader
things that 0.9.x is a higher version than 0.10.x. The safe way is just to
    sudo rm -rf /usr/local/lib/couchdb/erlang/lib/
before sudo make install.



View raw message