couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Debasish Ghosh <>
Subject Re: Problems with Query Server
Date Tue, 15 Sep 2009 11:36:04 GMT
Some more info on the problems ..

Using a source snapshot of 2009/04/23, all views and validations run fine
with Erlang 12B as well as 13B. If I switch to the trunk, things become very
very slow, so slow that I get process_timed_out. And for documents for which
validation fails I get a 500 with the error that I describe in the previous
mail below. This happens only for query servers - views and validations.
After some benchmarking I find that the step which becomes so slow is the
PUT of a document when I have a validation function associated with the
design document. Without the validation function it runs quite fast and

Has there been any change recently that I need to take into account ?

Any help will be appreciated ..

- Debasish

On Mon, Sep 14, 2009 at 4:07 PM, Debasish Ghosh <>wrote:

> Hi -
> I have implemented a View Server for Scala, which was working fine (with a
> snapshot of April 2009) till I tried a recent snapshot from the trunk (and
> Erlang R13B). It's a snapshot of today (Sep 14, 2009). I have the following
> observations :-
> 1. The Views (map/reduce functions written in Scala) run absolutely ok even
> now. Only noticeable change is that it has become very slow compared to the
> earlier version. Noet that I am not running with lots of data either.
> 2. None of the validations work now. It runs absolutely ok with the earlier
> version of CouchDB, which was being used with Erlang R12. Now I am getting a
> 500 for most of the validations that have some logic with the following
> exception :
> {"error":"normal","reason":"{gen_server,call,\n
> [couch_query_servers,\n
> {ret_proc,{proc,<0.562.0>,<<\"scala\">>,\n
> {couch_os_process,prompt},\n
> {couch_os_process,set_timeout},\n
> {couch_os_process,stop}}}]}"}
> 3. I am running Ubuntu .. sometimes, inconsistently I get a "connection
> refused" error as well. But it is not consistent and may not come the next
> time I run the same stuff.
> Any help will be appreciated.
> Thanks.
> - Debasish

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message