couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <>
Subject Re: badarg in browser?
Date Tue, 10 Feb 2009 23:30:35 GMT
You'll have to check the Document api to see if I'm right or not, but
when you PUT a document to a url, is it required to have the
appropriate _id attribute? Something like:

$ curl -X PUT -d '{"_id": "foo", "keys": ["param1", "param2",
"paramN"]}' http://localhost:5984/test/foo

Other than that, you could turn on debug output and see if the stack
trace is informative at all.

This is definitely an odd one. Maybe someone else has run into it?

Paul Davis

On Tue, Feb 10, 2009 at 6:22 PM, Wout Mertens <> wrote:
> Hi,
> I'm trying to run the couchdb svn head and I'm not able to create documents
> or run the test suite using Futon. I tried both Safari and Firefox.
> Troubleshooting further I tried curl:
> $ curl -X PUT -d '{"keys": ["param1", "param2", "paramN"]}'
> http://localhost:5984/test/foo
> {"error":"error","reason":"badarg"}
> This error is the same as what Safari and Firefox give me. CouchDB itself
> just says:
> [error] [<0.155.0>] Uncaught error in HTTP request: {error,badarg}
> [info] [<0.155.0>] - - 'PUT' /test/foo 500
> I'm running Erlang 5.6.0 and I tried several revisions, as far back as
> 722100. I suppose it's something in the supporting infrastructure? Any ideas
> on what this could be and how to troubleshoot?
> Note that it did work for me a couple of months ago, and I switched laptops
> since then, leading me to recompile erlang.
> Thanks,
> Wout.

View raw message