couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Bacon <>
Subject Re: Couchdb init issue (x86_64)
Date Mon, 10 Nov 2008 21:54:58 GMT
Awesome. Those rpm's worked. For some reason I had to reinstall the  
erlang rpm before it worked. Strange as it is the same one I installed  

Now I am having a different issue.

I have setup:

         ProxyPass /couch
         ProxyPassReverse /couch

in Apache (I tried rewrites too) and it seems to work except in both  
the rewrite and proxy I cannot:

1. Create a database. Just hangs.
2. The Overview spinner keeps spinning.
3. All the tests fail with this error:

Exception raised:{"message":"parseJSON","line":155,"sourceURL":"http:// 

Any ideas?


On Nov 10, 2008, at 6:25 AM, Ask Bjørn Hansen wrote:

> On Nov 7, 2008, at 14:45, Benjamin Bacon wrote:
>> I am a newbie to Couchdb. I built it from source today. Running  
>> CentOS 5.2 (x86_64). After getting the dependencies installed couch  
>> built fine. The issue I am having is starting the server. This is  
>> the error I get:
>> Apache CouchDB 0.9.0a712244-incubating (LogLevel=info) is starting.
>> {"init terminating in do_boot","wrong ELF class: ELFCLASS64"}
> That's a really weird error.  Was the erlang rpm x86_64?
> FWIW, I am running it on CentOS 5.2 (x86_64) with erlang from EPEL  
> and the js package recompiled from fedora.  I put the rpm's  
> temporarily up on
> if you want to give them a try.
>  - ask

View raw message