couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sho Fukamachi <>
Subject can't install on RHEL4 anymore
Date Sun, 23 Mar 2008 10:15:28 GMT
HI all,

Tried to update my old install on RHEL4 with the latest from trunk and  
I just can't get it to make. I think it's something to do with  
spidermonkey - I couldn't find any RPMs for that later than 1.5 or  
something. Maybe that's too old - ./configure runs, but make bombs out  

couch_js.c:424: error: `JSOPTION_XML' undeclared (first use in this  
make[3]: *** [couch_js.o] Error 1

which sounds like SpiderMonkey to me.

I decided to get a newer one, so downloaded the 1.7.0 js tarball from  
mozilla and extracted it, then ran configure telling it to look in  
that directory for  js-lib. Still doesn't work. I tried compiling  
SpiderMonkey, can't make anything work.

Has anyone got any idea what I'm doing wrong here? Surely I'm not the  
only person trying to install on RHEL4...


View raw message