couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Wenk <andyw...@apache.org>
Subject Re: [VOTE] Release Apache CouchDB 1.7.0-RC1
Date Mon, 06 Nov 2017 10:10:24 GMT
The vote passed. Cool! Anyway here my output ...


> On 5. Nov 2017, at 21:32, Jan Lehnardt <jan@apache.org> wrote:
> 
>> 
>> On 5. Nov 2017, at 21:10, Andy Wenk <andywenk@apache.org> wrote:
>> 
>> I downloaded:
>> 
>> https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.sha512
>> 
>> I get the following error 
>> 
>>> shasum -a 512 --check apache-couchdb-*.tar.gz.sha512
>> shasum: apache-couchdb-1.7.0.tar.gz.sha512: no properly formatted SHA1 checksum lines
found
> 
> mv apache-couchdb-1.7.0.tar.gz.sha512 apache-couchdb-1.7.0.tar.gz.sha512.gz
> gzip -d apache-couchdb-1.7.0.tar.gz.sha512.gz
> shasum -a 512 --check apache-couchdb-*.tar.gz.sha512
> 
> (not sure what the deal there is)

yep:

apache-couchdb-1.7.0.tar.gz: OK

> 
>> ++++
>> 
>> running make check, I get this error:
>> 
>> dyld: Library not loaded: @rpath/libcurl.4.dylib
>> Referenced from: /tmp/couchdb/dist/apache-couchdb-1.7.0/bin/couchjs_dev
>> Reason: Incompatible library version: couchjs_dev requires version 9.0.0 or later,
but libcurl.4.dylib provides version 7.0.0
>> [error] [<0.393.0>] OS Process Error <0.529.0> :: {os_process_error,
>>                                                  {exit_status,134}}
> 
> odd! Can you provide the outputs of:
> 
> otool -L /tmp/couchdb/dist/apache-couchdb-1.7.0/bin/couchjs_dev
> otool -L /path/to/libcurl.4.dylib # the path is in the previous output.

> otool -L /tmp/couchdb/dist/apache-couchdb-1.7.0/bin/couchjs_dev
/tmp/couchdb/dist/apache-couchdb-1.7.0/bin/couchjs_dev:
	@rpath/libcurl.4.dylib (compatibility version 9.0.0, current version 9.0.0)
	@rpath/libssh2.1.dylib (compatibility version 1.0.0, current version 1.0.1)
	@rpath/libssl.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	@rpath/libcrypto.1.0.0.dylib (compatibility version 1.0.0, current version 1.0.0)
	@rpath/libz.1.dylib (compatibility version 1.0.0, current version 1.2.11)
	/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1238.60.2)
	/usr/local/opt/spidermonkey/lib/libmozjs185.1.0.dylib (compatibility version 1.0.0, current
version 1.0.0)
	/usr/local/opt/nspr/lib/libplds4.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/local/opt/nspr/lib/libplc4.dylib (compatibility version 1.0.0, current version 1.0.0)
	/usr/local/opt/nspr/lib/libnspr4.dylib (compatibility version 1.0.0, current version 1.0.0)

Sorry, but I don’t know what @rpath/libcurl.4.dylib means … I assume libcurl4.dylib is
missing in /usr/local or somewhere … ?

Thanks for your help Jan

Cheers

Andy


> 
> Best
> Jan
> --
> 
> 
>> 
>> I am not sure how to fix this and appreciate any help.
>> 
>> Cheers
>> 
>> Andy
>> 
>> 
>> -- 
>> Andy Wenk
>> Hamburg - Germany
>> RockIt!
>> 
>> GPG public key: 
>> http://pgp.mit.edu/pks/lookup?op=get&search=0x45D3565377F93D29
>> 
>> 
>> 
>>> On 5. Nov 2017, at 20:42, Andreas Wenk <andreas@family-wenk.de> wrote:
>>> 
>>> thanks Dave - I did not recognise the double mention of tar.gz … 
>>> 
>>> -- 
>>> Andy Wenk
>>> Hamburg - Germany
>>> RockIt!
>>> 
>>> GPG public key: 
>>> http://pgp.mit.edu/pks/lookup?op=get&search=0x45D3565377F93D29
>>> 
>>> 
>>> 
>>>> On 4. Nov 2017, at 23:10, Dave Cottlehuber <dch@skunkwerks.at> wrote:
>>>> 
>>>> On Sat, 4 Nov 2017, at 22:55, Andy Wenk wrote:
>>>>> I get a 404 whne trying to GET the sha256 and sha512 files:
>>>> 
>>>> I should have mentioned that in my reply, sorry Andy.
>>>> 
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.asc
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.tar.gz.sha256
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.tar.gz.sha512
>>>> 
>>>> This was a subtle trick to fool mere mortals...  the amended URLs are:
>>>> 
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.sha256
>>>>>> wget https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/apache-couchdb-1.7.0.tar.gz.sha512
>>>> 
>>>> svn never lies.
>>>> https://dist.apache.org/repos/dist/dev/couchdb/source/1.7.0/rc.1/
>>>> 
>>>> A+
>>>> Dave
>>> 
>> 
> 
> -- 
> Professional Support for Apache CouchDB:
> https://neighbourhood.ie/couchdb-support/


Mime
View raw message