commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Pontarelli <>
Subject Re: [Fileupload] Missing character in the middle of a file
Date Tue, 05 Oct 2010 16:49:34 GMT
I'm heading out for a business trip today, so I might go silent on this thread for a week or
so. I'll try to post code when I get a chance and see if I can figure it out. I haven't tried
additional files yet, mostly because it should work for any file in the universe. I'll try
a few others though to see if it happens the same way with those.


On Oct 4, 2010, at 2:53 PM, Christopher Schultz wrote:

> Hash: SHA1
> Brian,
> On 10/4/2010 11:43 AM, Brian Pontarelli wrote:
>> I figured that the original File and the File written out by the
>> FileUpload would have different bytes at the start or end and it was
>> my mock input stream that was causing the issue. To test this theory
>> I opened both files in a HEX editor. What I found was that the files
>> differ by one a single byte and that byte is at position 305. The
>> other interesting thing I found was that the byte that exists in the
>> original and is missing from the FileUpload file is 'FF'.
> That's weird. Is the missing byte always at position 305? What variety
> of "test" files have you tried? Is it always 0xff that gets discarded?
> Could you post some of your test driver code, and some of the servlet
> code so we can see how they interact?
> - -chris
> Version: GnuPG v1.4.10 (MingW32)
> Comment: Using GnuPG with Mozilla -
> u6AAn1j+AJKZ/QH5SjcZ6wKp8jMAsyVi
> =CPV2
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message