commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Apache Commons VFS 2.1 rc1
Date Thu, 05 May 2016 22:19:10 GMT
Hi Stian,

Stian Soiland-Reyes wrote:

> Thanks, I've added ${hadoop.version} so it's easier to upgrade in the
> future, and also committed the <exclusion> of tools.jar
> 
> 
> I think the maven-jar-maven JDK9 issue is due to
> https://issues.apache.org/jira/browse/MJAR-206
> https://issues.apache.org/jira/browse/MJAR-205
> 
> so you would need to wait for maven-jar-plugin 3.0.0

I faced the same problem when I tested the release for commons-net earlier 
this week. At least there's nothing to blame for vfs.

> Not sure about the JspRuntimeContext class cast exception..
> 
> jdk.internal.loader.ClassLoaders$AppClassLoader (in module: java.base)
> cannot be cast to java.net.URLClassLoader
> 
> sounds like a bit naive casting by Jasper.  Perhaps we would then also
> need to force a newer version - this is PRETTY old:
> 
> [INFO] |  +- tomcat:jasper-compiler:jar:5.5.23:test
> [INFO] |  +- tomcat:jasper-runtime:jar:5.5.23:test
> 
> (This version is also coming in as a Hadoop test dependency)
> 
> Fixed in Tomcat 8.0.0 at least:
> 
> 
https://github.com/apache/tomcat/blob/TOMCAT_8_0_0/java/org/apache/jasper/compiler/JspRuntimeContext.java#L403
>

Fine. Again, we cannot blame vfs. I was just a bit astonished when I saw the 
stack trace on the console and later on Maven claimed a successful build.

Cheers,
Jörg



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message