cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dag Sonstebo <Dag.Sonst...@shapeblue.com>
Subject Re: Cannot resolve DNS and download.cloud.com(No template available while creating instance)
Date Wed, 26 Oct 2016 08:08:34 GMT
Hi Abdul,

You haven’t told us about your lab configuration – but in short you need to make sure
the default gateway on your public network (in an advanced zone) or your guest network (in
a basic zone) can route traffic to the public internet – reading between the lines I don’t
think you have a datacenter setup with raw internet traffic presented to your switches –
hence you need to configure a non-internet facing “public” or “guest” network which
has a gateway handling routing and NATing. 

With regards to your cloudbr1 question – please have a look at the following blog post we
published yesterday – it may explain how to configure your KVM host: http://www.shapeblue.com/networking-kvm-for-cloudstack/


Regards,
Dag Sonstebo
Cloud Architect
ShapeBlue

On 26/10/2016, 08:32, "Abdul Qayyum Halid" <haiy.halid@gmail.com> wrote:

    Hi Dag
    I had view that thread, any suggestion on cloudbr1 setup. According to
    shapeblue installation guide, there just disable the cloudbr1 by set
    bridge_port to none. Can you give the suggestion on how to make my cloudbr1
    connect to my public ip which is 203.xx.xx.xx instead of 172.16.xx.xx.
    Thanks
    
    On Wednesday, 26 October 2016, Dag Sonstebo <Dag.Sonstebo@shapeblue.com>
    wrote:
    
    > Hi Abdul,
    >
    > This was discussed in a thread a few days back – please see the email
    > thread with subject “SSVM unable to ping outside, only management server”.
    >
    > In short – you have a networking problem preventing the SSVM from reaching
    > your DNS server – subsequently it can not DNS name resolve anything.
    >
    > Regards,
    > Dag Sonstebo
    >
    > On 26/10/2016, 04:11, "Abdul Qayyum Halid" <haiy.halid@gmail.com
    > <javascript:;>> wrote:
    >
    >     Hello i'm going to setup basic cloudstack,my problem was as above. I am
    >     able to create SSVM and CPVM and the status is running and up.But
    > while i'm
    >     check the ssvm health through /usr/local/cloud/systemvm/ssvm-check.sh
    > it
    >     shows as below...
    >
    >     ================================================
    >     First DNS server is  172.16.238.6
    >     PING 172.16.238.6 (172.16.238.6): 48 data bytes
    >     --- 172.16.238.6 ping statistics ---
    >     2 packets transmitted, 0 packets received, 100% packet loss
    >     WARNING: cannot ping DNS server
    >     route follows
    >     Kernel IP routing table
    >     Destination     Gateway         Genmask         Flags Metric Ref    Use
    >     Iface
    >     0.0.0.0         172.16.135.254  0.0.0.0         UG    0      0
    > 0 eth2
    >     169.254.0.0     0.0.0.0         255.255.0.0     U     0      0
    > 0 eth0
    >     172.16.134.0    0.0.0.0         255.255.254.0   U     0      0
    > 0 eth1
    >     172.16.134.0    0.0.0.0         255.255.254.0   U     0      0
    > 0 eth2
    >     172.16.238.6    172.16.135.254  255.255.255.255 UGH   0      0
    > 0 eth1
    >     ================================================
    >     ERROR: DNS not resolving download.cloud.com
    >     resolv.conf follows
    >     nameserver 172.16.238.6
    >     nameserver 172.16.238.7
    >
    >     Below is my /etc/network/interfaces configuration. For your
    > information, i
    >     place my template at /export/secondary rather than /mnt/secondary.
    >
    >     # interfaces(5) file used by ifup(8) and ifdown(8)
    >     auto lo
    >     iface lo inet loopback
    >
    >     # The primary network interface
    >     auto eth0
    >     iface eth0 inet manual
    >
    >     # Public network
    >     auto cloudbr0
    >     iface cloudbr0 inet static
    >         address 172.16.135.133
    >         netmask 255.255.254.0
    >         gateway 172.16.135.254
    >         dns-nameservers 172.16.238.7 172.16.238.6
    >         dns-domain UTP.EDU.MY
    >     #   bridge_ports eth0.200
    >         bridge_ports eth0
    >         bridge_fd 5
    >         bridge_stp off
    >         bridge_maxwait 1
    >
    >     # Private network
    >     auto cloudbr1
    >     iface cloudbr1 inet manual
    >         bridge_ports none
    >         bridge_fd 5
    >         bridge_stp off
    >         bridge_maxwait 1
    >
    >     Below is my SSVM /etc/network/interfaces
    >
    >     auto lo eth0 eth1 eth2
    >     iface lo inet loopback
    >
    >     iface  eth0 inet static
    >       address 169.254.0.193
    >       netmask 255.255.0.0
    >     iface  eth1 inet static
    >       address 172.16.135.146
    >       netmask 255.255.254.0
    >     iface  eth2 inet static
    >       address 172.16.135.11
    >       netmask 255.255.254.0
    >
    >
    >     thank you for help.. ;-)
    >
    >
    >
    > Dag.Sonstebo@shapeblue.com <javascript:;>
    > www.shapeblue.com
    > 53 Chandos Place, Covent Garden, London  WC2N 4HSUK
    > @shapeblue
    >
    >
    >
    >
    


Dag.Sonstebo@shapeblue.com 
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK
@shapeblue
  
 

Mime
View raw message