cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krishnanand Khambadkone <>
Subject Re: [EXTERNAL] Re: Caused by: com.datastax.driver.core.exceptions.ReadTimeoutException:
Date Wed, 17 Apr 2019 16:02:41 GMT
 Thank you gentlemen for all your responses.   Reading through them I was able to resolve
the issue by doing the following,
a.  Creating an index on one of the query fieldsb.  Setting page size to 200
Now the query runs instantaneously.
    On Wednesday, April 17, 2019, 7:12:21 AM PDT, Shaurya Gupta <>
 As already mentioned in this thread, ALLOW FILTERING should be avoided in any scenario.
It seems to work in test scenarios, but as soon as the data increases to certain size(a few
MBs), it starts failing miserably and fails almost always.

On Wed, Apr 17, 2019, 6:44 PM Durity, Sean R <> wrote:

If you are just trying to get a sense of the data, you could try adding a limit clause to
limit the amount of results and hopefully beat the timeout.

means the data model does not support the query and will not scale -- in this case, not even
on one node. Design a new table to support the query with a proper partition key (and any
clustering keys).

Sean Durity

-----Original Message-----
From: Dinesh Joshi <>
Sent: Wednesday, April 17, 2019 2:39 AM
Subject: [EXTERNAL] Re: Caused by: com.datastax.driver.core.exceptions.ReadTimeoutException:

More info with detailed explanation:


> On Apr 16, 2019, at 11:24 PM, Mahesh Daksha <> wrote:
> Hi,
> how much data you are trying to read in the single query? is it large in size or normal
text data.
> Looking at the exception it seems the node is unable to deliver data within stipulated
time. I have faced similar issue with the response data in huge in size (some binary data).
But it was solved as we spread the data across multiple rows.
> Thanks,
> Mahesh Daksha
> On Wed, Apr 17, 2019 at 11:42 AM Krishnanand Khambadkone <>
> Hi,  I have a single instance cassandra server.  I am trying to execute a query with
ALLOW FILTERING option.  When I run this same query from cqlsh it runs fine but when I try
to execute the query through the java driver it throws this exception.  I have increased
all the timeouts in cassandra.yaml file and also included the read timeout option in the SimpleStetement
query I am running.  Any idea how I can fix this issue.
> Caused by: com.datastax.driver.core.exceptions.ReadTimeoutException: Cassandra timeout
during read query at consistency LOCAL_ONE (1 responses were required but only 0 replica responded)

To unsubscribe, e-mail:
For additional commands, e-mail:


The information in this Internet Email is confidential and may be legally privileged. It is
intended solely for the addressee. Access to this Email by anyone else is unauthorized. If
you are not the intended recipient, any disclosure, copying, distribution or any action taken
or omitted to be taken in reliance on it, is prohibited and may be unlawful. When addressed
to our clients any opinions or advice contained in this Email are subject to the terms and
conditions expressed in any applicable governing The Home Depot terms of business or client
engagement letter. The Home Depot disclaims all responsibility and liability for the accuracy
and content of this attachment and for any damages or losses arising from any inaccuracies,
errors, viruses, e.g., worms, trojan horses, etc., or other items of a destructive nature,
which may be contained in this attachment and shall not be liable for direct, indirect, consequential
or special damages in connection with this e-mail message or its attachment.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message