cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Jirsa <jji...@gmail.com>
Subject Re: Database not getting updated
Date Fri, 11 May 2018 12:21:10 GMT
This usually happens when you’ve got weird timestamps or a delete in the future - check your
clocks, make sure your timestamp resolution uses the same units in all applications (likely
microseconds), make sure you’re running NTP everywhere

-- 
Jeff Jirsa


> On May 11, 2018, at 5:37 PM, <Vishal1.Sharma@ril.com> <Vishal1.Sharma@ril.com>
wrote:
> 
> Dear community,
>  
> Sometimes I’ve noticed that the changes done in the database, even when done successfully
are not reflected e.g. I added/deleted a row via cqlsh/Datastax C++ driver, the command/API
was successful, yet when I fetched the contents of the table, the row that I had added/deleted,
was missing/still present. Has anybody, noticed something similar before?
> I’ve had this observation on the latest 3.11.2(earlier I had observed this on 3.0.14).
There were 2 nodes in my cluster, replication factor was 2 and read/write consistency was
also 2.
>  
> Thanks and regards,
> Vishal Sharma
> 
> "Confidentiality Warning: This message and any attachments are intended only for the
use of the intended recipient(s), are confidential and may be privileged. If you are not the
intended recipient, you are hereby notified that any review, re-transmission, conversion to
hard copy, copying, circulation or other use of this message and any attachments is strictly
prohibited. If you are not the intended recipient, please notify the sender immediately by
return email and delete this message and any attachments from your system.
> 
> Virus Warning: Although the company has taken reasonable precautions to ensure no viruses
are present in this email. The company cannot accept responsibility for any loss or damage
arising from the use of this email or attachment."

Mime
View raw message