cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Shuler <mich...@pbandjelly.org>
Subject DATASTAX COMMUNITY DEBIAN REPOSITORY ADVISORY - August 6, 2015
Date Fri, 07 Aug 2015 00:32:14 GMT
I'm passing this along from the DataStax Support folks.

This shouldn't affect new installs, since the install instruction will 
pull the new expiry, but for users that already have a DSC/DSE Debian 
repository configured, apt-get update/install will warn about the 
expired key after 8/13.

curl -L http://debian.datastax.com/debian/repo_key | sudo apt-key add -

I just tested out updating the key I have in apt-key with the curl 
command below, and update/install seems to work just fine.

Shout if you have any trouble!

Kind regards,
Michael

======================================================================

DATASTAX SUPPORT ADVISORY - August 6, 2015
* DSE Debian Repository Key *
* Set to expire August 13, 2015 *
If you have any questions, contact DataStax support.

If you install or upgrade DataStax Community (DSC) or DataStax 
Enterprise (DSE) software using the Aptitude Package Management (APT) 
application, please read this advisory.

The signing key used to sign the DataStax repositories will expire 
August 13th. The purpose of signing the repository is to ensure software 
packages come from a trusted source.  For security reasons the signing 
key used by DataStax is set to expire after a certain number of years.

Required Action:
If you upgrade an existing installation or for some other reason have 
the public repository key installed on your local system, please install 
the new key before August 13th, 2015. The procedure to import the key or 
re-import the new key has not changed.  The key can be updated by 
running the command below on the server that is using the Datastax 
repository.

curl -L http://debian.datastax.com/debian/repo_key | sudo apt-key add -

For more information please refer to our documentation:
http://docs.datastax.com/en/datastax_enterprise/4.7/datastax_enterprise/install/installDEBdse.html



If you have any questions or concerns please contact DataStax Support.

Thank you,
DataStax Support

Mime
View raw message