cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carlos Scheidecker <nando....@gmail.com>
Subject Re: Small bug on Cassandra 2.1.0-rc3 and fix
Date Fri, 11 Jul 2014 21:49:32 GMT
Mark,

Sure!

Actually it might be a package problem. Not installing Cassandra by hand as
I need to test it across a bigger dev cluster.

As I am using Ubuntu 14.04 on the test nodes using the following repository:

### Cassandra
deb http://www.apache.org/dist/cassandra/debian 21x main # disabled on
upgrade to saucy
deb-src http://www.apache.org/dist/cassandra/debian 21x main # disabled on
upgrade to saucy
### Cassandra

Therefore, it seems to be a packaging problem as the
file /usr/share/cassandra/cassandra.in.sh is the culprid.

Here is its entire content after the fix:

root@hp-dv7-7243cl:/etc/apt# cat /usr/share/cassandra/cassandra.in.sh

# The directory where Cassandra's configs live (required)
CASSANDRA_CONF=/etc/cassandra

CASSANDRA_HOME=/usr/share/cassandra

# The java classpath (required)
if [ -n "$CLASSPATH" ]; then
    CLASSPATH=$CLASSPATH:$CASSANDRA_CONF
else
    CLASSPATH=$CASSANDRA_CONF
fi

for jar in /usr/share/cassandra/lib/*.jar; do
    CLASSPATH=$CLASSPATH:$jar
done

for jar in /usr/share/cassandra/*.jar; do
    CLASSPATH=$CLASSPATH:$jar
done

CLASSPATH="$CLASSPATH:$EXTRA_CLASSPATH"


# set JVM javaagent opts to avoid warnings/errors
if [ "$JVM_VENDOR" != "OpenJDK" -o "$JVM_VERSION" \> "1.6.0" ] \
      || [ "$JVM_VERSION" = "1.6.0" -a "$JVM_PATCH_VERSION" -ge 23 ]
then
    JAVA_AGENT="$JAVA_AGENT -javaagent:$CASSANDRA_HOME/lib/jamm-0.2.6.jar"
fi




On Fri, Jul 11, 2014 at 3:02 PM, Mark Reddy <mark.reddy@boxever.com> wrote:

> Hi Carlos,
>
> I have just downloaded 2.1.0-rc3 to validate this and the cassandra.in.sh
> contains the correct reference to the jamm-0.2.6.jar
>
> This can also been seen on the trunk:
> https://github.com/apache/cassandra/blob/trunk/bin/cassandra.in.sh
>
> I am unsure why you are seeing jamm-0.2.5.jar in your cassandra.in.sh
> file if you have taken down a fresh 2.1.0-rc, can you give any further
> information?
>
>
> Mark
>
>
> On Fri, Jul 11, 2014 at 9:49 PM, Carlos Scheidecker <nando.nlp@gmail.com>
> wrote:
>
>> Hello all,
>>
>> Probably not here that I should submit it, but I have been testing
>> Cassandra 2.1.0 for quite a while.
>>
>> I have tried to subscribe to the dev list as well.
>>
>> Even now on rc3, there is still a small bug on cassandra.in.sh used,
>> among others, for nodetool settings.
>>
>> The error is that it is still loading jamm-0.2.5.jar while the package
>> has been updated to 0.2.6 on this version.
>>
>> Where it says:
>>
>> then
>>     JAVA_AGENT="$JAVA_AGENT -javaagent:$CASSANDRA_HOME/lib/jamm-0.2.5.jar"
>> fi
>>
>> Should be inside cassandra.in.sh
>>
>> then
>>     JAVA_AGENT="$JAVA_AGENT -javaagent:$CASSANDRA_HOME/lib/jamm-0.2.6.jar"
>> fi
>>
>> Otherwise, of course, nodetool will not start unless you have version
>> 0.2.5 from somewhere else in your classpath.
>>
>>
>>
>

Mime
View raw message