cassandra-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Krzysztof Zarzycki <>
Subject cassandra [2.1.0-rc4] does not filter data out when using WHERE clause on cluster column
Date Mon, 28 Jul 2014 16:32:40 GMT
Hi everyone,
I have a weird, invalid situation with my cluster. I have a table on which
I'm running some SELECTs with WHERE clause filtering on cluster columns,
but the rows are not getting filtered out.
 select * from page_view where website_id = xxx and user_id = 'some_user'
and page_id =0; -- tried also page_id<0 >0

 website_id | user_id   | page_id  | ...
        xxx | some_user | 21044533 | ...
...more rows here, none with page_id=0

The filtering on other (partition) columns runs fine. Only the clustering
column is somewhat malfunctioning.

Important is, how I got to this table:
1. I collected data with Cassandra version 2.0.8
2. I snapshotted the data, and removed the main copy from cluster's data.
3. I upgraded cluster to version 2.1.0-rc4
4. I've recreated the schema of tables in new version.
5. I ran sstableloader on the data to load data to new upgraded cluster.
6. I spotted the problem with filtering.
7. I've tried to run nodetool repair, nodetool upgradesstables -a , neither

Do you have any ideas how to curate my data?
It might be cumbersome, but possible to just copy data out (to e.g. json)
and back in. But anyway, I believe it might be a bug in 2.1.0-rc4. Do you
have at least ideas on how to investigate what the problem is?

Thank you for any help,
-- Krzysztof Zarzycki

View raw message