arrow-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weber, Eugene" <efwe...@evoforge.org>
Subject LLVM Question
Date Thu, 24 Jun 2021 14:43:15 GMT
Hi,


I'm running Centos 7. In the Arrow C++ build documentation it states that you are using LLVM
8. I can install llvm-toolset-7.0 which contains llvm/clang version 7.0.1. To get a more recent
version of llvm on Centos 7 it would need to be built from source. I tried to do this a few
times following various online "recipes", but failed. Not the clearest/simplest process I've
seen. 😉 I decided to just give version 7.0.1 a try.


Attached is my build script and build log. It appears to build successfully, but it does give
these messages:

-- clang-tidy not found

-- clang-format not found

-- Could NOT find ClangTools (missing: CLANG_FORMAT_BIN CLANG_TIDY_BIN)


I tried adding the following to my build script:

export CLANG_TIDY_BIN=/opt/rh/llvm-toolset-7/root/usr/bin

export CLANG_FORMAT_BIN=/opt/rh/llvm-toolset-7.0/root/usr/bin

export PATH=/opt/rh/llvm-toolset-7/root/usr/bin:$PATH

But the messages remain.

When I run unit tests, all 71 tests pass. So at this point there doesn't appear to be any
issue using llvm/clang 7.0.1.

Are the "not found" messages OK?
Is it OK to use llvm/clang 7.0.1?

Thanks,

Gene



Mime
View raw message