arrow-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neal Richardson <neal.p.richard...@gmail.com>
Subject Re: Boost
Date Mon, 03 May 2021 21:59:10 GMT
That's right, I noticed that 1.71.0 wasn't on sourceforge when we were
moving off of bintray URLs--that's why we bumped up to 1.75 at that time
(also included in arrow 4.0).

Neal

On Mon, May 3, 2021 at 2:34 PM Niranda Perera <niranda.perera@gmail.com>
wrote:

> @Neal It seems like there sourceforge artifacts are missing for boost
> 1.71.0. But I tried 1.72.0 and it worked.
> export ARROW_BOOST_URL="
> https://sourceforge.net/projects/boost/files/boost/1.72.0/boost_1_72_0.tar.gz/download
> <https://www.google.com/url?q=https://sourceforge.net/projects/boost/files/boost/1.72.0/boost_1_72_0.tar.gz/download&sa=D&source=hangouts&ust=1620161862426000&usg=AFQjCNGaE8t8M40ixkzW4ZaDH3yHAu34vw>
> "
>
> From Cylon project's POV we are in the process of upgrading to arrow 4.0
> from 2.0 ATM.
>
> Best
>
>
> On Mon, May 3, 2021 at 11:06 AM Neal Richardson <
> neal.p.richardson@gmail.com> wrote:
>
>> Bintray was shut down Saturday (May 1). The surest fix for this is to
>> upgrade to the latest (4.0.0) release of arrow, which does not have any
>> references to bintray. If you need to be on an older version, you can
>> download the correct boost source tarball (they're hosting on sourceforge
>> now, I believe) and set the environment variable ARROW_BOOST_URL to point
>> to the local file.
>>
>> Neal
>>
>> On Mon, May 3, 2021 at 8:01 AM Niranda Perera <niranda.perera@gmail.com>
>> wrote:
>>
>>> I also noticed the same error since yesterday (Sunday).
>>>
>>> On Mon, May 3, 2021 at 10:44 AM Wes McKinney <wesmckinn@gmail.com>
>>> wrote:
>>>
>>>> Can you create a Jira issue and provide more information about exactly
>>>> what's going wrong?
>>>>
>>>> On Mon, May 3, 2021 at 2:10 AM Matt Youill <matt.youill@airmettle.com>
>>>> wrote:
>>>> >
>>>> > Hi,
>>>> >
>>>> > I started getting a strange build failure for thrift this afternoon
>>>> (no
>>>> > install target). Digging into it, it looks like boost is the culprit.
>>>> > Two of the three mirrors for boost are failing and the last doesn't
>>>> look
>>>> > like what it should. Namely, these fail to download:
>>>> >
>>>> > https://dl.bintray.com/ursalabs/arrow-boost/boost_1_71_0.tar.gz
>>>> >
>>>> >
>>>> https://dl.bintray.com/boostorg/release/1.71.0/source/boost_1_71_0.tar.gz
>>>> >
>>>> > And this one (that successfully downloads) doesn't look right...
>>>> >
>>>> > https://github.com/boostorg/boost/archive/boost-1.71.0.tar.gz
>>>> >
>>>> > AFAICT the arrow build expects it to contain headers, but headers =
>>>> false.
>>>> >
>>>> > Matt
>>>> >
>>>> >
>>>>
>>>
>>>
>>> --
>>> Niranda Perera
>>> https://niranda.dev/
>>> @n1r44 <https://twitter.com/N1R44>
>>>
>>>
>
> --
> Niranda Perera
> https://niranda.dev/
> @n1r44 <https://twitter.com/N1R44>
>
>

Mime
View raw message