Hello,
When I using pyarrow flight client get remote data, I encounter the "assertion failed" problem:  

It seems the grpc bug. And it is similar with the previous problem: https://issues.apache.org/jira/browse/ARROW-7689 .
And the record of grpc is : https://github.com/grpc/grpc/issues/20311

In my project, the version of pyarrow is 2.0.0, and the version of grpcio is 1.33.2. Both are the latest version.
 

When I change the version of pyarrow from 2.0.0 to 0.17.1, the problem disappeared.

I am confused why the latest version of pyarrow will cause the bug? And the old version will not?
Is this a bug? 

Thanks a lot.