ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tiger Wang (Jira)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-25497) problems with AMBARI Installation Guide
Date Wed, 25 Mar 2020 12:47:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-25497?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tiger Wang updated AMBARI-25497:
--------------------------------
    Description: 
[https://cwiki.apache.org/confluence/display/AMBARI/Installation+Guide+for+Ambari+2.7.5]

 

*1. RAT is complaing too many unapproved licenses*

Which can be solved by

 

changing 

 

{{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6"}}

 

to

 

{{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6" *{color:#ff8b00}-Drat.skip=true{color}*}}

 

*2. node version is too old that it causes ambari-admin failed to build.*

 

Should add a step to update ambari-admin/pom.xml with changes like

 


{{<nodeVersion>v10.19.0</nodeVersion>}}
{{ <npmVersion>6.13.4</npmVersion>}}


 

  was:
[https://cwiki.apache.org/confluence/display/AMBARI/Installation+Guide+for+Ambari+2.7.5]

 

{{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6"}}

should be

{{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6" *{color:#ff8b00}-Drat.skip=true{color}*}}


> problems with AMBARI Installation Guide
> ---------------------------------------
>
>                 Key: AMBARI-25497
>                 URL: https://issues.apache.org/jira/browse/AMBARI-25497
>             Project: Ambari
>          Issue Type: Documentation
>            Reporter: Tiger Wang
>            Priority: Major
>
> [https://cwiki.apache.org/confluence/display/AMBARI/Installation+Guide+for+Ambari+2.7.5]
>  
> *1. RAT is complaing too many unapproved licenses*
> Which can be solved by
>  
> changing 
>  
> {{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6"}}
>  
> to
>  
> {{mvn -B clean install jdeb:jdeb -DnewVersion=2.7.5.0.0 -DbuildNumber=5895e4ed6b30a2da8a90fee2403b6cab91d19972
-DskipTests -Dpython.ver="python >= 2.6" *{color:#ff8b00}-Drat.skip=true{color}*}}
>  
> *2. node version is too old that it causes ambari-admin failed to build.*
>  
> Should add a step to update ambari-admin/pom.xml with changes like
>  
> {{<nodeVersion>v10.19.0</nodeVersion>}}
> {{ <npmVersion>6.13.4</npmVersion>}}
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message