activemq-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rob...@apache.org
Subject [activemq-artemis] branch main updated: ARTEMIS-3270: move enforcer execution config so it overrides parent execution
Date Tue, 15 Jun 2021 16:17:39 GMT
This is an automated email from the ASF dual-hosted git repository.

robbie pushed a commit to branch main
in repository https://gitbox.apache.org/repos/asf/activemq-artemis.git


The following commit(s) were added to refs/heads/main by this push:
     new a8c17fa  ARTEMIS-3270: move enforcer execution config so it overrides parent execution
a8c17fa is described below

commit a8c17fa290f5eff5aa0975c07ce67a0629f932eb
Author: Robbie Gemmell <robbie@apache.org>
AuthorDate: Tue Jun 15 17:11:36 2021 +0100

    ARTEMIS-3270: move enforcer execution config so it overrides parent execution
    
    The change in 90101f5b5435922fd0310ec8abb50d186245fcce / #3595 didnt work
    as expected since the existing enforcer check already wasnt working. It
    isnt overriding the apache parent, which is checking for 3.0.x. Moving
    the execution into the build element, alongside the java version check,
    allows it to replace the parent execution and enforce 3.5.0+ is used.
---
 pom.xml | 29 ++++++++++++++---------------
 1 file changed, 14 insertions(+), 15 deletions(-)

diff --git a/pom.xml b/pom.xml
index 54e3347..cc1ac95 100644
--- a/pom.xml
+++ b/pom.xml
@@ -1362,21 +1362,6 @@
               <groupId>org.apache.maven.plugins</groupId>
               <artifactId>maven-enforcer-plugin</artifactId>
               <version>${maven.enforcer.plugin.version}</version>
-              <executions>
-                <execution>
-                  <id>enforce-maven-version</id>
-                  <goals>
-                    <goal>enforce</goal>
-                  </goals>
-                  <configuration>
-                    <rules>
-                      <requireMavenVersion>
-                        <version>3.5.0</version>
-                      </requireMavenVersion>
-                    </rules>
-                  </configuration>
-                </execution>
-              </executions>
             </plugin>
             <plugin>
                <groupId>org.codehaus.mojo</groupId>
@@ -1529,6 +1514,20 @@
                  </rules>
                </configuration>
              </execution>
+             <execution>
+               <id>enforce-maven-version</id>
+               <goals>
+                 <goal>enforce</goal>
+               </goals>
+               <configuration>
+                 <rules>
+                   <requireMavenVersion>
+                     <version>3.5.0</version>
+                     <message>You must use Maven 3.5.0+ to build</message>
+                   </requireMavenVersion>
+                 </rules>
+               </configuration>
+             </execution>
            </executions>
          </plugin>
          <plugin>

Mime
View raw message